Considérations sur la mise à niveau en place - Metasys - LIT-12012162 - MS-ADSxxx-x - MS-ADXxxx-x - Server - Metasys Server - 10.1

Instructions d’installation et de mise à niveau de Metasys Server

Brand
Metasys
Product name
Metasys Server
Document type
Installation Guide
Document number
LIT-12012162
Version
10.1
Revision date
2020-11-16
Language
Français (France)

Avant de lancer le processus de mise à niveau en place, examinez le tableau suivant.

Tableau 1. Considérations sur la mise à niveau en place

Données ou élément

Détails

Référence ou action

Condition courante de tous les logiciels du système Metasys

Avant de commencer la mise à niveau, assurez-vous que tous les logiciels d’application Metasys actuellement chargés fonctionnent correctement. En particulier, vérifiez les applications suivantes : Metasys Database Manager, Metasys Export Utility et Metasys UI.

Reportez-vous aux systèmes d’aide et guides de l’utilisateur correspondants.

Fonctionnement courant des logiciels Metasys Advanced Reporting System et Energy Essentials

Si le site de l’intervention a un ADX qui utilise Metasys Advanced Reporting System (ARS) et Energy Essentials, assurez-vous que ces applications fonctionnent correctement. Si ARS est installé mais ne fonctionne pas ou est corrompu, il est possible que vous ne parveniez pas à effectuer avec succès une mise à niveau en place. À la place, désinstallez complètement l’ADX, puis réinstallez-le avec Advanced Reporting version 10.1

Pour désinstaller l’ADX, consultez Désinstaller le logiciel Metasys Server.

Version courante du système d'exploitation Windows.

Avant de commencer la mise à niveau, assurez-vous que le système d'exploitation courant est pris en charge. Dans la négative, appliquez les mises à jour requises pour que les versions correspondent à celles répertoriées ici.

Remarque : Pour Windows 8.1 uniquement, démarrez Windows Powershell et exécutez la commande suivante pour vérifier que la Mise à jour 1 (KB2919355) est installée : get-hotfix -id KB2919355. Si le correctif d'urgence est introuvable, mettez à jour l’ordinateur vers Windows 8.1 avec la Mise à jour 1.

Pour vérifier le système d'exploitation Windows, ouvrez une fenêtre d’invite de commande et exécutez la commande msinfo32. Vérifiez que la version est du niveau suivant ou d’un niveau supérieur :

Windows 10 : Version 1809 10.17763

Windows 8.1 : Version 6.3.9600

Windows 7 avec SP1 : Version 6.1.7601

Windows Server 2016 : Version 10.0.14393

Windows Server 2012 R2 : Version 6.3.9600

Windows Server 2012 : Version 6.2.9200

Version courante du logiciel Microsoft® SQL Server®

Si votre système Metasys utilise actuellement une version du logiciel SQL Server qui n’est plus prise en charge, vous devez le mettre à niveau vers une version plus récente. Le programme d’installation de Metasys Server s’arrête s’il détecte que la version et le Service Pack de SQL Server actuellement installés ne sont pas pris en charge. Pour la liste des versions de SQL Server prises en charge, consultez Liste de vérification des logiciels requis pour l’installation et la mise à niveau.

Voir Vérifier que votre ordinateur a une version prise en charge du logiciel SQL Server d’installée.

Pour plus d'informations sur l’installation ou la mise à niveau du logiciel SQL Server, reportez-vous au document SQL Server Installation and Upgrade Instructions (LIT-12012240).

Version courante du logiciel ADS/ADX

Si l'ordinateur est doté de la version 7.x ou d’une version antérieure du logiciel ADS/ADX , vous devez désinstaller le logiciel ADS/ADX existant. Lorsque vous y êtes invité, sélectionnez la suppression des clés de licence car vous effectuez une mise à niveau vers une nouvelle version majeure du logiciel.

Vous devez aussi désinstaller le logiciel ADS/ADX si vous effectuez une mise à niveau vers une build du logiciel du même niveau de version (par exemple, de la 10.1.0.3570 à la 10.1.0.3847). Après la désinstallation, vous pouvez installer la build plus récente.

Si l'ordinateur est doté de la version 8.x ou d’une version ultérieure du logiciel ADS/ADX , vous pouvez choisir de le mettre à niveau au lieu de commencer par le désinstaller.

Voir Introduction à la désinstallation du logiciel Metasys Server.

La présence d’applications tierces n’est plus requise.

Si vous mettez à niveau le logiciel ADS/ADX de la version 10.0 à 10.1, plusieurs des applications tierces installées avec la version 10.0 ne sont plus nécessaires et peuvent, en fait, consommer inutilement les ressources de l’ordinateur. Après la mise à niveau vers la version 10.1, vous devriez éliminer ces composants.

Voir Désinstaller des composants logiciels tiers.

Condition courante générale des systèmes CVC surveillés par Metasys

Exécutez et imprimez un récapitulatif Alarm et un récapitulatif Override pour documenter les éventuels problèmes système existants.

Metasys® Site Management Portal Help (LIT-1201793) .

Observateur d'événements de Windows

Contrôlez si l’Observateur d'événements de Windows ne contient pas de messages d’erreurs relatifs au système, à ADS et à MDM.

Consultez la documentation du système d'exploitation Windows.

Espace disque disponible

Vérifiez l’espace disque disponible et nettoyez les fichiers variés et provisoires qui peuvent être supprimés pour récupérer de l’espace disque.

Consultez la documentation du système d'exploitation Windows.

Base de données de sécurité

Si la version courante du système Metasys est la version 5.2 ou une version antérieure, créez une sauvegarde de la base de données de sécurité en utilisant le Security Backup/Restore Wizard de SCT. Sélectionnez Tools > Security Backup/Restore > Backup.

Si la version courante du système Metasys est la version 6.0 ou une version ultérieure, aucune sauvegarde de la base de données de sécurité distincte n’est nécessaire car la base de données de sécurité fait partie de la base de données d’archives. Sauvegarder l’archive effectue aussi une sauvegarde de sécurité.

Reportez-vous à la section Security Database Backup and Restore du document Metasys® Site Management Portal Help (LIT-1201793) pour la version 5.2 ou une version antérieure.

Base de données d’archives

En utilisant la version existante de SCT, téléchargez la base de données d’archives sur le serveur en veillant à sélectionner l’option Include Security. Créez ensuite une sauvegarde de la base de données d’archives. Effectuez également une exportation de la base de données avec SCT.

Les sauvegardes se trouvent dans C:\ProgramData\Johnson Controls\MetasysIII\DatabaseFiles

Sections Upload, Backing Up an Archive Database et Export Database du document Metasys® SCT Help (LIT-12011964) .

Comptes utilisateurs et mots de passe

Procurez-vous tous les noms d’utilisateur administrateur et mots de passe nécessaires pour l’installation à la mise à niveau du logiciel. Cela inclut le compte et le mot de passe de l'administrateur système SQL (sa). Les clients qui ne veulent pas communiquer ces informations d’identification s’organiseront pour que le DBA SQL soit présent. Sinon, le DBA peut créer un compte admin SQL temporaire avec des droits de SA juste pour l’installation du logiciel, qui pourra être supprimé par la suite.

Consultez l’administration informatique du client.

Préférences

Les préférences système ne sont pas conservées durant une mise à niveau vers la version 10.1. Enregistrez vos fichiers de préférences dans un emplacement sûr avant la mise à niveau, puis remettez ces fichiers dans l’emplacement approprié une fois la mise à niveau terminée.

Les préférences que vous devez enregistrer peuvent inclure des fichiers de sons d’alarme et des sélections de couleur, des affichages de démarrage et des liens vers des applications externes.

À partir de SCT 11, les processus de téléchargement vers et depuis le serveur incluent les préférences utilisateur. SCT ne télécharge cependant pas sur le serveur les préférences utilisateur depuis un Site Director NAE.

Configuring and Maintaining Preferences Appendix du document ADS/ADX Commissioning Guide (LIT-1201645) ou du document NAE Commissioning Guide (LIT-1201519) .

Listes d'objets

Les listes d’objets stockées dans les moteurs réseau ne sont pas conservées durant une mise à niveau vers la version 10.1. Les listes d’objets sont enregistrées dans des fichiers par la fonctionnalité Global Search lorsque vous enregistrez les résultats de recherche. Enregistrez vos fichiers de listes d’objets dans un emplacement sûr avant la mise à niveau, puis remettez ces fichiers dans l’emplacement approprié une fois la mise à niveau terminée.

À partir de SCT 11, les processus de téléchargement vers et depuis le serveur incluent les listes d’objets. SCT ne télécharge cependant pas sur le serveur les listes d’objets depuis un Site Director NAE.

Configuring and Maintaining Preferences Appendix du document ADS/ADX Commissioning Guide (LIT-1201645) ou du document NAE Commissioning Guide (LIT-1201519) .

Fichiers Config ou Properties 1

Si vous avez personnalisé des fichiers pour votre système, veuillez à noter ces personnalisations avant d’effectuer la mise à niveau. Lorsque vous effectuerez la mise à niveau, ces fichiers seront écrasés et vous perdrez vos paramètres personnalisés. Après la mise à niveau, veillez à réappliquer vos paramètres personnalisés.

Remarque : Lors de la mise à niveau, ne remplacez pas le nouveau fichier par une copie de l’ancien. D’autres paramètres du fichier peuvent avoir été modifiés pour améliorer les performances système ou prendre en charge de nouvelles fonctionnalités. Au lieu de remplacer le nouveau fichier par une copie de l’ancien, réappliquez les paramètres personnalisés dans le nouveau fichier.

La documentation de chaque produit couvre les procédures de personnalisation. Il est également possible que le personnel d’assistance vous indique comment mettre à jour les fichiers.

Données historiques

Installez le Metasys Database Manager sur le Metasys Server s’il n’est pas déjà présent. Ensuite, un jour ou plusieurs heures avant la mise à niveau programmée du système, utilisez Metasys Database Manager pour sauvegarder les bases de données historiques, qui incluent les audits (JCIAuditTrails), les alarmes (JCIEvents), les tendances (JCIHistorianDB), les annotations (JCIItemAnnotation), les tendances de l’IU Metasys (JCIReportingDB) et les Autorisations d’espaces de l’IU Metasys (SpacesAuthorization). 2et le système de reporting (MetasysReporting). Nous vous recommandons de sélectionner l’option de réindexage, même si cela augmente considérablement la durée de ce processus.

Remarque : Si le système existant est autorisé à s’exécuter après la sauvegarde de la base de données, il y aura des trous dans les données historiques entre le moment de la fin de la sauvegarde et celui de la migration des bases de données sur le nouveau serveur et de leur mise en ligne.

Pour les étapes d’installation, reportez-vous au Metasys Database Manager Installation Guide (LIT-12011553). Reportez-vous ensuite à la section Backing Up a Database du document Metasys® Database Manager Help (LIT-12011202) .

Versions coexistantes de Metasys Server et du logiciel SCT.

Metasys Server 10.1 peut coexister avec SCT 13.2 sur un même ordinateur.

Reportez-vous au document SCT Installation and Upgrade Instructions (LIT-12012067) .

Type d'encodage BACnet

Le processus de mise à niveau de l’archive modifie l’attribut BACnet Encoding Type sous l’objet Site. Lorsqu’un site est mis à niveau vers la version 10.1 avec SCT 13.2, le BACnet Encoding Type de l’objet Site est automatiquement remplacé par ISO 10646 UTF-8 durant le processus de mise à niveau de l’archive. Si vous avez besoin du BACnet Encoding Type UCS-2, veillez à remettre cet attribut sur UCS-2 une fois la mise à niveau de l’archive terminée.

Reportez-vous à la section Site Object - Attributes du document Metasys SMP Help (LIT--1201793).

Appariement d’appareils

Depuis Metasys version 10.0, un processus d’authentification plus sûr a été mis en œuvre entre les NxE mis à jour et le Site Director, qui requiert l’appariement d’appareils. Cette fonctionnalité est régulée par un nouveau attribut de l’objet Site appelé Advanced Security Enabled. Si vous effectuez une mise à niveau vers la version 10.0 ou une version ultérieure à partir d’une version plus ancienne, Advanced Security Enabled est mis par défaut sur False. Cependant, si vous effectuez une mise à niveau de la version 10.1 ou d’une version ultérieure vers une nouvelle build ou une nouvelle version, et qu’Advanced Security Enabled est sur True, les NxE ne seront plus appariés à leurs Site Directors.

Avant d’effectuer une mise à niveau de la version 10.1 vers une nouvelle build de la version 10.1 ou une nouvelle version, suivez les étapes ci-après :

  1. Appariez tous les moteurs réseau avec le Metasys Server.
  2. En utilisant SCT, téléchargez Metasys Server avec sécurité pour enregistrer les informations d’appariement dans l’archive.
  3. Effectuez la mise à niveau du Metasys Server, mais ne mettez pas à jour les moteurs.
  4. En utilisant SCT, effectuez ensuite une copie de sécurité sur le Metasys Server qui vient d’être mis à niveau.
  5. Vérifiez que tous les moteurs sont désormais appariés.

Revenez à Bienvenue.

(pour revenir à la fenêtre précédente, cliquez sur le bouton Retour de votre navigateur).

1 Les fichiers .config contiennent les paramètres réseau Metasys personnalisés pour les fonctionnalités, notamment les réglages du Destination Delivery Agent (DDA) d’impression série pour un NAE, l’ADX du Metasys Advanced Reporting System et l’Action Queue dans SCT. Des exemples de fichiers .config que vous pouvez avoir personnalisés comprennent web.config et ActionQueue.exe.config. Les fichiers de propriétés contiennent aussi des informations relatives à la résolution des noms et d’autres paramètres système.
2 Si vous effectuez une mise à niveau depuis Metasys version 8.0, vous devez utiliser SQL Server Management Studio pour sauvegarder la base de données SpacesAuthorization car l’opération de sauvegarde n’est pas disponible pour cette base de données avec Metasys Database Manager version 8.0.