Operating system requirements - Metasys - LIT-12012067 - Software Application - System Configuration Tool - 15.0

SCT Installation and Upgrade Instructions

Product name
System Configuration Tool
Document type
Installation Guide
Document number
LIT-12012067
Version
15.0
Revision date
2022-06-29

The following Windows operating systems support SCT software:

  • Windows® 10 Enterprise LTSC (21H2) (64-bit)
  • Windows® 10 Pro and Windows 10 Enterprise Editions versions 2004, 21H1, and 21H2 (64-bit). For all future Windows 10 updates after version 21H2, we will evaluate and certify that Metasys software can support the updates before we provide guidance on support.
  • Windows® Server® 2019 (version 1809 or later) (64-bit)
  • Windows® Server® 2016 (version 1607 or later) (64-bit)

Refer to the following guidelines to install SCT:

  • If you install the SCT on a server and you do not have an earlier release of SCT installed, first install or verify that you have a supported version of SQL Server software. If you install SCT on a desktop operating system without a version of SQL software installed, the SCT setup automatically installs SQL Server Express. For details, see Verifying your computer has a supported version of SQL Server software installed.
    Note: If you have an unsupported version of SQL server software installed, the SCT installation does not install a supported version automatically. You must update or upgrade the version of SQL or install a supported version manually.
  • Do not install the system software on a computer that was updated from an older version of Windows, such as from Windows 7 to Windows 10. This process can leave behind files and registry settings that can adversely affect the installation of system software. Prepare the computer by performing a clean installation using the Windows installation media.
  • The System Configuration Tool Setup installs Microsoft .NET Framework version 4.7.2. For Windows 10, Windows Server 2016, and Windows Server 2019, a valid connection to Windows Update must be available for the SCT setup to be successful with the installation of .NET Framework 4.7.2. An error message appears if the prerequisite is not present.