Security updates management - Metasys - LIT-12011279 - General System Information - Metasys System - 10.1

Network and IT Guidance Technical Bulletin

Brand
Metasys
Product name
Metasys System
Document type
Technical Bulletin
Document number
LIT-12011279
Version
10.1
Revision date
2019-12-20
Language
English

A Johnson Controls engineering team regularly evaluates newly released Microsoft security updates ranked Critical or Important for their effect on the Metasys system. The results of the update analysis can be obtained from Johnson Controls technical support.

For Metasys system engines, we send out applicable security updates through our support channels with instructions for applying them. For the computer-based components of the Metasys system (Metasys server, NxE85, and LCS85), we recommend that you apply Microsoft security updates and hotfixes as soon as they are released by the Microsoft Corporation.

To ensure higher security for the Site Management Portal, a private JRE is required at Release 6.0 or later that provides isolation between Metasys software and the Internet. The public Java® Runtime Environment (JRE) that was required at earlier Metasys software releases is no longer necessary for Release 6.0 or later, but it is still a requirement for any older release of Metasys software. The Launcher puts down the private JRE required by Release 6.0 or later. You install it when you first browse to the Site Management Portal UI from a client computer or when you newly install Metasys system software. Thereafter, you use the Launcher to access the Site Management Portal UI. Refer to the Launcher Installation Guide (LIT-12011783) for instructions about how to install the Launcher application.

Note: If you use any applications from a release prior to Release 6.0 or later, you must continue to use the public JRE required for that particular software release.