Upgrading an NIE59 at Release 9.0 with integrations to Release 11.0 - Metasys - LIT-12013148 - System Integration - KNX Vendor Integration - 11.0

Network Engine Commissioning for KNX Vendor Integration Application Note

Brand
Metasys
Product name
KNX Vendor Integration
Document type
Application Note
Document number
LIT-12013148
Version
11.0
Revision date
2021-06-18
Language
English

About this task

Important: The Advanced Security Enabled feature indicates whether the site uses the advanced security settings. This attribute provides an improved layer of security between Metasys Site Directors and devices. With this attribute set to true, backward-compatible methods of communication between the Site Director and its network engines are disabled, which means a Site Director at Release 10.0 or later discards all communication attempts from network engines prior to Release 10.0. At Release 10.1 or later, the Advanced Security Enabled attribute is defaulted to True. This setting applies to the entire site, so change this attribute set to False if you have any network engines prior to Release 10.0. When you change this attribute to True, a user message appears to indicate that all network engines prior to Release 10.0 remain online, but are disconnected from the site because they no longer communicate with the Site Director. If this message appears, click OK to continue and set the attribute to True, or Cancel to keep the attribute set to False.

To upgrade an NIE59 to an NAE55 with integrations to Release 11.0, complete the following steps:

Procedure

  1. Log on to SCT with the commissioning laptop and open the archive for the NIE59.
  2. Upload the NIE59 archive with SCT.
  3. Upgrade the NIE59 archive from current release to Release 11.0.
  4. Reimage the NIE59 with Release 10.1 using the PXE process.
  5. Open the NIE59 archive and open the Hardware tab of the NIE59 engine integration object.
  6. Verify the correct name according to Table 1 is in the Vendor driver field. Enter the file name if it is not.
    Note: The Vendor driver file name is case sensitive.
    Table 1. Vendor files to specify for an NIE59
    Network Engine Integration type

    Old name first driver

    New name first driver

    NIE59 KNX KNXDriver_N50.dll libKNXDriver.so
  7. Save your changes.
  8. Download the NIE59 archive into the NIE59.
  9. After the download is complete, log on to the NIE59, and verify the integration in the upgraded NIE59 is online.