Using an import file to insert field points - Metasys - LIT-12013148 - System Integration - KNX Vendor Integration - 11.0

Network Engine Commissioning for KNX Vendor Integration Application Note

Brand
Metasys
Product name
KNX Vendor Integration
Document type
Application Note
Document number
LIT-12013148
Version
11.0
Revision date
2021-06-18
Language
English

About this task

You need an EIB session file to complete the steps to insert field points using an import file (.esf file). You can use the .esf file with the Mass Changes Tool (MCT) to create an import file (.imp file), which you use to insert field points. If you do not have an .esf file, contact the KNX programmer.

If you do not have the MCT installed on your computer, go to the Systems Integration Services (SIS) page at https://my.jci.com/sites/EUSysIntegrationProj/Pages/Home-New.aspx. Click Downloads > SIS Engineering Tools > MCT . The program and support files for the MCT are provided. You can run the MCT in demo mode until it is licensed. You must have a licensed version in order to complete the directions in this section.

To license the MCT software, open the MCT and go to Help > About Mass Changes Tool . Click either Load License File (JCI Internal Only) or Create License Request Form (External Users). After you license the MCT, complete the following steps.

Procedure

  1. Run the Mass Changes Tool.
  2. Go to File > New . The New File - Type window appears.
    Figure 1. New File - Type

  3. In the window, click KNX Integration, and then click Next. The New File - KNX Integration window appears.
    Figure 2. New File - KNX integration
  4. Click the browse button in this window and in the next window, and browse to the .esf file.
  5. Click the file name and then click Open. The Import KNX File window appears and displays the file details.
    Figure 3. Import KNX File

  6. Modify the Point Type, Data Type, Update at Startup, Special Handler, and Bit Mask parameters as desired for each point by clicking the pulldown and selecting the appropriate value.
    Note: Points that are defined as Uncertain by the .esf file may be modified like any other point.
    Figure 4. Selecting the data type

  7. When you are finish the changes, click OK. The New File - KNX Integration window appears again.
  8. Click into each field to edit the General Data and Vendor Configuration Data as necessary.
    Note: These values must match the attributes in the Metasys SMP or OAS user interface. See Table 1 for a list of parameter descriptions.
    Table 1. Device parameters

    Category

    Description

    Unique ID

    The Unique ID of the gateway under which all KNX data points are saved. The Unique ID is part of the Object Name.

    Name

    The Object Name attribute on the Metasys field device object.

    Description

    The Description attribute on the Metasys field device object.

    Vendor Reference

    The Vendor Reference attribute on the Metasys field device object.

    Vendor Configuration Data

    The IP Address in the Vendor Configuration Data attribute (parameter 1 of the field device object). It is the IP address of the KNX IP interface/router device.

    Vendor Configuration Data

    Tunneling or Routing mode.

  9. Click Next. The New File Points window appears.
    Figure 5. New File - Points

  10. Configure the data points as requires. You can modify any value that has a drop-down menu.
  11. Click Next. The New File Points Selection window appears.
    Figure 6. New File - Points Selection

  12. Click a data point that you want to import, and then click > to move it to the panel on the right. Repeat until all desired points are on the right. Click >> if you want to move all data points to the right.
  13. Click Finish.
    Figure 7. Import file window

  14. Click the device name in the navigation menu on the left, and then click Update. All of the configured points for the import file appear in the window.
    Figure 8. Points for import file