Prerequisite Software Checklist for Installation and Upgrade - Metasys - LIT-12012162 - MS-ADS05U-0 MS-ADX10U-0 MS-ADX10SQL-0 MS-ADX25U-0 MS-ADX25SQL-0 MS-ADX50U-0 MS-ADX50SQL-0 MS-ADX50SQL2-0 MS-ADX100U-0 MS-ADX100SQL2-0 - Server - Metasys Server - 12.0.50

Metasys Server Installation and Upgrade Instructions

Brand
Metasys
Product name
Metasys Server
Document type
Installation Guide
Document number
LIT-12012162
Version
12.0.50
Revision date
2023-10-12
Product status
Active
Language
English
Before you begin with the Metasys Server installation or upgrade, review Table 1 to verify that you have the required software. The table also indicates where you can obtain each software component.
Note: If you purchased Metasys Server software that includes SQL Server software (for example, MS-ADX25SQL-0), the SQL Server package is provided in a .zip file. Simply use a file extraction tool such as WinZip™ or 7-Zip File Manager to extract the .zip file to the server's hard drive.
Note: Do not install Metasys on a Domain Controller. A Domain Controller provides the Active Directory service to network users and computers; stores directory data; and manages user and domain interactions including the login process, authentication, and directory searches.
Table 1. Prerequisite Software Checklist

Software Component

Product

Where to Obtain

Operating System (select one) 1

Windows® 10 Pro and Windows 10 Enterprise Editions versions 21H2, 22H2 (64-bit). For all future Windows 10 updates after version 22H2, Johnson Controls will evaluate and certify that Metasys software can support the updates before we provide guidance on support. 2

ADS /SCT

Microsoft Corporation

Windows® Server® 2019 (version 1809 or later) (64-bit)

ADX /SCT

Windows® Server® 2016 (version 1607 or later) (64-bit)

Operating System (OS) Components (installed by Metasys Server)

Internet Information Services (IIS) (included with OS)

ADS/ADX /SCT

OS media

Microsoft Message Queuing (MSMQ)

Miscellaneous (select all)

Microsoft .NET Framework 3.5 SP1 or 3.5.1

ADS/ADX /SCT

OS Media

 

Microsoft .NET Framework 6.0.6

(installed by Metasys Server)

 

Microsoft Silverlight® 5.0 or higher 3

Microsoft Silverlight is no longer supported. You can view the Graphics+ graphics in the Metasys UI.

Database (select one)

SQL Server® 2019 Express with CU19 (64-bit)

ADS /SCT

License Portal

Microsoft Download Center

SQL Server® 2017 Express with CU31 (64-bit)

SQL Server® 2016 Express with SP3 GDR (64-bit)

SQL Server® 2019 with CU19 (64-bit) 4

(Standard or Enterprise Edition)

ADX /SCT

Microsoft Corporation

SQL Server® 2017 with CU31 (64-bit) 4

(Standard or Enterprise Edition)

SQL Server® 2016 with SP3 GDR (64-bit) 4

(Standard or Enterprise Edition)

Database Tools

SQL Installer Tool

ADS /SCT

License Portal

Microsoft SQL Server Management Studio

License Portal or Microsoft Download Center

Reporting Services

Microsoft Report Viewer 2012 Redistributable Package 5

ADX

License Portal or Microsoft Corporation

1 We highly recommend that the computer you want to use for Metasys software had its operating system installed on a cleanly formatted hard disk. If you use a computer that was upgraded from a previous version of Windows, files and registry settings left behind after the upgrade may adversely affect the installation of Metasys system software.
2 Metasys system software does not support the touchscreen interface that is featured in the Windows 10 operating system.
3 Required for viewing Graphics+ files on Site Management Portal software clients.
4 At Release 12.0.50, Metasys Advanced Reporting System is compatible with SQL Server 2017, and SQL Server 2016 software, but is not compatible with SQL Server 2019.
5 Required for reports generated by the Metasys Advanced Reporting System. Use Report Viewer 2012 Redistribution Package for both SQL Server 2017 and SQL Server 2016 software.