Editing a User View - Metasys - LIT-12011942 - Software Application - ODS Server - 10.1

Metasys Open Data Server Help

Brand
Metasys
Product name
ODS Server
Document type
User Guide
Document number
LIT-12011942
Version
10.1
Revision date
2019-10-14
Language
English

About this task

Notes:
  • You cannot create, edit, or delete a user view in online mode with Basic Access.
  • The Edit menu or Right-click > Delete functions are not used to delete items from a User View while the User View Editor is open. Using either function permanently deletes selected items from the archive.

To edit a user view:

Procedure

  1. Browse to the user view (in either the User Views folder in the All Items navigation tree or by selecting the user view tab).
  2. Double-click the user view. The user view editor appears in the Display frame.
  3. Click Edit and work with the user view as follows:
    • Use the New Folder button to add a folder.
    • Use the Add Reference(s) and Add Tree(s) buttons to add references to items.
    • Use drag-and-drop functionality to add references to items from the navigation frame (User View [online] or All Items tree) to a User View in Edit mode.
    • Use drag-and-drop functionality to add references to items in a User View from the Global Search Results table. View both the Global Search Viewer and the User View in the display frame (using a multiple panel view). Click Edit in the User View. Then drag the desired items from the Search Results table to the User View.
    • Press the Ctrl key and drag and drop a tree (only from the navigation frame) to a User View in Edit mode to add an entire tree to the User View. This functionality does not apply to the Global Search Results table.
    • Select one or more items and use the Remove button to remove items.
    • Sort the items in the user view using the Sort Ascending and Sort Descending buttons.
    • Use the Move Up and Move Down buttons to reorganize the order of the items.
    • Use the Edit Label button to rename items.
    • Use the Find and Replace button to resolve broken references after changing the Site Director or to duplicate user view hierarchies for supervisory devices with similar configurations. For details, see Find and Replace.

    For information on the buttons and functionality in the Tree View tab, see the Tree View Tab section.

  4. Click Save when finished.