LIP system requirements - Metasys - LIT-12011793 - Software Application - Language Installation Program - 12.0

Language Installation Program Installation Guide

Brand
Metasys
Product name
Language Installation Program
Document type
Installation Guide
Document number
LIT-12011793
Version
12.0
Revision date
2022-05-20
Product status
Active
Language
English

The LIP tool requires the following system components and settings:

  • A computer with 2 MB free hard disk space for the LIP program files and 30 MB free hard disk space for each language.
  • Administrative rights for the current user.
  • A local area network connection to the supervisory controller if updating a supervisory controller. A dial-up connection does not support the updates that the LIP dictionary performs.
  • Microsoft .NET Framework 4.7.2.
  • A PDF reader to open the online help file, such as Adobe® Reader®.

LIP is compatible with any of the following operating systems:

  • Windows® 10 Pro and Windows 10 Enterprise Editions versions 2004, 21H1, and 21H2 (64-bit). For all future Windows 10 updates after version 21H2, we will evaluate and certify that Metasys software can support the updates before we provide guidance on support.

  • Windows® Server® 2019 (version 1809 or later) (64-bit)

  • Windows® Server® 2016 (version 1607 or later) (64-bit)
    Note: Before you use the LIP, and before you install the Metasys server or SCT software, set the computer’s regional settings and the default language used by the Microsoft® SQL Server database to the same locale as the site default language. For details, refer to the Microsoft documentation.

Install the LIP tool on the same computer that the software application exists. For example if you want to change the languages files for the OAS, you must install the LIP tool on the same computer as the OAS application, but you must uninstall the LIP after you install the languages

Important: The LIP tool is not FIPS 140-2 compliant. If you install LIP on a FIPS 140-2 compliant Site Director, you must uninstall LIP after you add the additional languages.

For a list of LIP compatible servers, software applications, and network engines, see the following list:

  • Metasys Server (ADS/ADX, or OAS)
  • Metasys UI
  • Johnson Controls System Configuration Tool (JCT)
  • SCT
  • NAE85/LCS85
  • SNE
  • SNC
  • N50 Class Device
  • N40 Class Device

The LIP verifies that the software prerequisites are present on your computer before the LIP continues with the installation.