Software prerequisites - Metasys - LIT-12011623 - Supervisory Device - LCS85 Controller - 11.0

LCS85 Installation and Upgrade Guide

Brand
Metasys
Product name
LCS85 Controller
Document type
Installation Guide
Document number
LIT-12011623
Version
11.0
Revision date
2020-10-30
Language
English

The installation or upgrade of the LCS85 software requires one of the following 64-bit Windows server-class operating systems:

  • Windows® Server® 2019 (version 1803 or later) (64-bit)

  • Windows® Server® 2016 with Update (KB4512495) (64-bit)

We strongly advise that you do not browse to the Metasys Site Management Portal (SMP) UI from a computer running a server-class operating system. By default, Windows® Internet Explorer Enhanced Security Configuration is enabled on server-class operating systems, and may block the Launcher download page from which you install the Launcher application to access the SMP. Open the SMP UI from a client computer that is not running a server-class OS.