Installing LCS85 software - Metasys - LIT-12011623 - Supervisory Device - LCS85 Controller - 11.0

LCS85 Installation and Upgrade Guide

Brand
Metasys
Product name
LCS85 Controller
Document type
Installation Guide
Document number
LIT-12011623
Version
11.0
Revision date
2020-10-30
Language
English

About this task

Note: To upgrade releases prior to Release 10.0, you must uninstall the software before you can upgrade. The LCS85 installer prompts you to uninstall the previous release. Although the installer allows an upgrade from Release 10.0 to Release 11.0, best practice is to uninstall the previous version.
Important: The Advanced Security Enabled feature indicates whether the site uses the advanced security settings. This attribute provides an improved layer of security between Metasys Site Directors and devices. With this attribute set to true, backward-compatible methods of communication between the Site Director and its network engines are disabled, which means a Site Director at Release 10.0 or later discards all communication attempts from network engines prior to Release 10.0. At Release 11.0, the Advanced Security Enabled attribute is defaulted to True. This setting applies to the entire site, so change this attribute set to False if you have any network engines prior to Release 10.0. When you change this attribute to True, a user message appears to indicate that all network engines prior to Release 10.0 remain online, but are disconnected from the site because they no longer communicate with the Site Director. If this message appears, click OK to continue and set the attribute to True, or Cancel to keep the attribute set to False.
Note: For an LCS85 at Release 10.0 or later, there may be a requirement to run Metasys on a lower priority Network Interface Card (NIC). In cases like this, you must manually modify the N50.ini file to use the lower priority NIC as you do not get the option at install to chose the NIC.

Procedure

  1. Connect the computer monitor, keyboard, and mouse to the LCS85, if they are not already connected, and power on the LCS85 computer and monitor.
  2. Manually, generate a backup of your databases before you uninstall the previous release.
  3. Download the LCS85 software to a location on your computer.
  4. Use Windows File Explorer to navigate to the folder where you downloaded the LCS85 software.
  5. Double-click MetasysLonWorksControlServer_11.0.exe to start the installation.
    Note: The LCS85 installer provides an upgrade path, click Upgrade, and then click Finish. If the LCS85 installer does not provide an upgrade path and the message Metasys LCS8520 was detected appears, uninstall the previous release of LCS85, then try to install again.
  6. To install the LCS85 software to the default location, click Install and go to step 9. To install to a user-specified location, click Custom to select a custom installation location.
  7. Select an installation location and click OK. The new path displays in the Install Path text box.
  8. Click Install. A progress bar displays the progress of the installation.
  9. Click Finish.
    Important: You must license your LCS85 software after installation and then restart your machine for the license to take effect. Go to Licensing the LCS85.
  10. Go to Installing and licensing a new LonWorks software driver and complete all of the steps in that section.