Appendix: Upgrading the LonWorks software driver - Metasys - LIT-12011623 - Supervisory Device - LCS85 Controller - 11.0

LCS85 Installation and Upgrade Guide

Brand
Metasys
Product name
LCS85 Controller
Document type
Installation Guide
Document number
LIT-12011623
Version
11.0
Revision date
2020-10-30
Language
English

After you upgrade your server, it is important to also upgrade your LonWorks software driver. The LonWorks software driver upgrade contains the necessary fixes and enhancements required to ensure the best performance of your LCS85 server. Because not all Metasys releases require a driver update, check your driver version before using this appendix. See Checking the LonWorks software driver version. Use this appendix only if you need to upgrade your LonWorks software driver to the current version.

You can install LonWorks software driver upgrades over the existing drivers. This scenario is applicable if you have an existing LCS85 software driver and a new version is released that contains fixes and enhancements. If you install the LonWorks software driver over the existing drivers, skip the instructions in Preserving your database during driver upgrade and Removing an existing software driver and driver components. You must run FastUpd.exe during installation of the Remote Network Interface (RNI) client driver. You do not need to reboot until all software updates are installed.

If you have issues with driver functionality after you install driver upgrades over the existing drivers, then you must perform a new driver installation. You must follow all instructions in this appendix and run FastInst.exe during the installation of the RNI client driver. See Appendix: Upgrading the LonWorks software driver.

Note: Make sure to upgrade your LCS85 server to the latest Metasys release before you upgrade your LonWorks software driver. If your LCS85 server is at the latest Metasys release, you can skip the Preserving your database during driver upgrade section. The Metasys upgrade does not retain the database; it requires an SCT download.