Creating Aliased Graphics - Metasys - LIT-12012116 - Server - Metasys UI - 7.0

Johnson Controls System Configuration Tool (JCT) Help

Brand
Metasys
Product name
Metasys UI
Document type
User Guide
Document number
LIT-12012116
Version
7.0
Revision date
2023-09-01
Language
English

How do I create aliased graphics for an engine-only site?

Creating graphics with aliased bindings for use on engine-only sites is a multi-step process using both SCT and JCT. In the following procedure, both tools are needed to successfully create graphics that contain aliased bindings for engine only archives.
Note: The following procedure works for aliasing field points that are directly mapped below a field device. This process does not work for cases where the field points are mapped into folders below a field device.
  1. Launch SCT and open an archive that has an engine as the Site Director.
    Important: If you do not have a recent backup of the archive, create a backup before you proceed.
  2. To add a server, complete the following steps:
    1. From the Insert menu, select Server.
    2. Select ADS and complete the Insert Server Wizard using the default selections.
      Note: The name of the server does not matter, as the server is only temporary and deleted in a later step.
  3. To insert an equipment definition, complete the following steps:
    1. Expand the newly added ADS server and select the Equipment Definitions folder.
    2. Click Facility > Prepare Rapid Archive > Insert Equipment Definition. Give the equipment definition a descriptive name.
      Note: Alternatively, import an equipment definition that you previously exported from another archive and then update the short names as-needed to match your controllers.
    3. Edit the equipment definition to include all the points needed for your aliased graphic.
      Note: For more information on building equipment definitions, refer to the Insert Equipment Definition section in the SCT: System Configuration Tool Help (LIT-12011964) .
  4. Launch JCT and open the archive from the previous steps. From the User menu, click Feature Management and Graphics Manager.
  5. From the Location list, select Equipment Definitions.
  6. To create a graphic, complete the following steps:
    1. In the Graphics list, click + or + ADD ALIASED GRAPHIC. The New Graphic window opens.
    2. From the list, select the appropriate equipment template. For example, if you are creating a graphic for several VAVs, select Terminal Unit and the template that mostly contains the short names of the points on the VAVs.
    3. In the Name field, enter a name for the graphic.
      Note: The following are invalid characters for a graphic name: <, >, :, ", /, \, ?, *, |, @, #, .(period), and , (comma).
    4. If required, in the Description field, enter a description.
    5. From the Authorization Category list, select the category that you require.
    6. Click CREATE.
  7. To modify and add bindings to the graphic, in the Graphics Editor, complete the following steps:
    1. Add alias binding(s) to key data modules in the graphic from the equipment definition that you created.
    2. Replace any template bindings with mismatched short names by deleting the bindings and using drag/drop to add aliased points in their place.
    3. Modify symbols to update any aliased bindings with mismatched short names.
    4. Remove any unnecessary bindings or symbols.
    5. Click SAVE.
  8. On the Tools tab, click EXPORT GRAPHICS, and in the Export window, complete the following steps:
    1. On the SELECT SOURCE page, from the Available sources list, select the ADS. Click the Right Arrow icon to add the device to the Selected sources list.
    2. Click NEXT.
    3. On the CHOOSE CONTENTS page, select the check boxes for the aliased graphic(s) that you created or modified. Clear the check boxes for any templates and the Master Layer.
    4. Click EXPORT. Complete the export and note the file location of the export file.
  9. In SCT, to delete the server that you added, complete the following steps:
    Important: When you delete the server, the Equipment Definition that you created or modified will no longer exist in your archive. If you want to use it in the future, export the equipment definition before you proceed.
    1. Select the server and from the Edit menu, select Delete Items.
    2. If your archive includes more than one engine on the site, confirm that the expected engine has been promoted to Site Director. If necessary, change the Site Director by modifying the site object's Site Director Reference.
  10. In JCT, click User menu > Archive > Refresh All Archives. You are logged out of JCT.
  11. Log back on to JCT and open the engine only archive.
  12. To import, your graphic, complete the following steps:
    1. From the User menu, click Feature Management and Graphics Manager.
    2. On the Tools tab, click IMPORT GRAPHICS.
    3. On the SELECT FILE page, click Choose File. Browse to the .export file that you want to import and click Open. To confirm that the file is from a trusted source, select the check box.
    4. Click NEXT.
    5. On the SELECT DESTINATION page, select the engine(s) where you want to add the aliased graphic(s). Click IMPORT. The aliased graphic(s) imports into the Graphics folder on each selected engine.
    6. Click CLOSE.
  13. In SCT, the aliased graphic(s) is now visible in the engine's Graphics folder. To apply the aliased graphic to controllers, complete the following steps:
    1. Select all of the controllers that you intend to apply the aliased graphic to.
    2. Right click, and select Modify.
    3. Select the check box for the Graphic attribute in the Graphic Association section, and modify its value by choosing the aliased graphic that applies to the selected controllers.
    4. Select the check box for the Graphic Alias attribute and then enter an asterisk * in its edit field.
      Note: When you enter an asterisk for the value of Graphic Alias, SCT will automatically fill-in the alias string for each controller with the controller's item reference.
    5. Click Send.
  14. In JCT, click User menu > Archive > Refresh All Archives. You are logged out of JCT.
  15. Log back on to JCT.
  16. Verify that the aliased graphics are functional by clicking on the controllers and validating the point data correctly resolves to the fully qualified references.
  17. In SCT, to open the Manage Archive Wizard click Tools > Manage Archive and then synchronize or download the engine(s) to which you added the aliased graphic.