Felddatenpunkte mithilfe einer Importdatei einfügen - Metasys - LIT-12013148 - System Integration - KNX Vendor Integration - 11.0

Inbetriebnahme einer Automationsstation für die KNX-Integration – Anwendungshinweis

Brand
Metasys
Product name
KNX Vendor Integration
Document type
Application Note
Document number
LIT-12013148
Version
11.0
Revision date
2021-07-05
Language
Deutsch

Warum und wann dieser Vorgang ausgeführt wird

Um Felddatenpunkte mithilfe einer Importdatei einfügen zu können, benötigen Sie eine EIB-Sitzungsdatei (Dateiendung .esf). Mit dem Mass Changes Tool (MCT) kann aus der .esf-Datei eine Importdatei (Dateiendung .imp) erstellt werden, die dann zum Einfügen von Felddatenpunkten dient. Sollte keine .esf-Datei vorliegen, wenden Sie sich bitte an den KNX-Programmierer.

Falls das MCT nicht auf Ihrem Computer installiert ist, rufen Sie die „Systems Integration Services“-Seite (SIS) auf: https://my.jci.com/sites/EUSysIntegrationProj/Pages/Home-New.aspx. Klicken Sie dort auf Downloads > SIS Engineering Tools > MCT (Downloads > Technische SIS-Tools > MCT). Dort finden Sie die Programm- und Supportdateien für das MCT. Solange Sie keine MCT-Lizenz haben, können Sie das Tool im Demomodus ausführen. Um die folgenden Anleitungsschritte befolgen zu können, benötigen Sie jedoch eine lizenzierte Version.

Um die MCT-Software zu lizenzieren, öffnen Sie im MCT die Option Help > About Mass Changes Tool (Hilfe > Infos zum Mass Changes Tool). Klicken Sie dort entweder auf Load License File (JCI Internal Only) (Lizenzdatei laden [nur JCI-Mitarbeiter]) oder auf Create License Request Form (External Users) (Formular zur Lizenzanforderung erstellen [externe Anwender]). Gehen Sie nach der Lizenzierung wie unten beschrieben vor.

Prozedur

  1. Starten Sie das Mass Changes Tool (MCT).
  2. Öffnen Sie das Menü File > New (Datei > Neu). Daraufhin erscheint das Fenster New File - Type (Neue Datei – Typ).
    Abbildung 1. Neue Datei – Typ

  3. Klicken Sie in diesem Fenster auf KNX Integration (KNX-Integration) und dann auf Next (Weiter). Das Fenster New File - KNX Integration (Neue Datei – KNX-Integration) öffnet sich.
    Abbildung 2. Neue Datei – KNX-Integration
  4. Klicken Sie auf die Suchschaltfläche und suchen Sie in dem sich öffnenden Fenster nach der .esf-Datei.
  5. Klicken Sie auf den Dateinamen und dann auf Open (Öffnen). Das Fenster Import KNX File (KNX-Datei importieren) erscheint und zeigt Details zur Datei an.
    Abbildung 3. KNX-Datei importieren

  6. Bearbeiten Sie ggf. die Parameter Point Type (Datenpunkttyp), Data Type (Datentyp), Update at Startup (Aktualisierung beim Start), Special Handler (Sondermodus) und Bit Mask (Bit-Maske), indem Sie auf das entsprechende Drop-down-Menü klicken und den gewünschten Wert auswählen.
    Anmerkung: Auch Datenpunkte, die in der .esf-Datei als Uncertain (Unsicher) definiert sind, können ganz normal bearbeitet werden.
    Abbildung 4. Datentyp auswählen

  7. Wenn Sie alle gewünschten Änderungen vorgenommen haben, klicken Sie auf OK. Nun öffnet sich wieder das Fenster New File - KNX Integration (Neue Datei – KNX-Integration).
  8. Klicken Sie ggf. in die einzelnen Felder und bearbeiten Sie die Parameter General Data (Allgemeine Daten) und Vendor Configuration Data (Konfigurationsdaten Lieferant).
    Anmerkung: Diese Werte müssen mit den Attributen im Metasys-Liegenschaftsportal oder in der OAS-Benutzeroberfläche übereinstimmen. Tabelle 1 enthält Beschreibungen der einzelnen Parameter.
    Tabelle 1. Geräteparameter

    Kategorie

    Beschreibung

    Eindeutige ID

    Die eindeutige ID des Gateways, unter der alle KNX-Datenpunkte gespeichert werden. Die eindeutige ID ist Teil des Objektnamens.

    Name

    Entspricht dem Attribut „Object Name“ (Objektname) des Metasys-Feldgerätobjekts.

    Beschreibung

    Entspricht dem Attribut „Description “ (Beschreibung) des Metasys-Feldgerätobjekts.

    Lieferantenreferenz

    Entspricht dem Attribut „Vendor Reference“ (Lieferantenreferenz) des Metasys-Feldgerätobjekts.

    Konfigurationsdaten Lieferant

    Die IP-Adresse im Attribut „Vendor Configuration Data“ (Konfigurationsdaten Lieferant), d. h. Parameter [1] des Feldgerätobjekts. Entspricht der IP-Adresse des KNX-IP-Schnittstellenrouters.

    Konfigurationsdaten Lieferant

    Tunneling- oder Routing-Modus.

  9. Klicken Sie auf Next (Weiter). Daraufhin erscheint das Fenster New File - Points (Neue Datei – Datenpunkte).
    Abbildung 5. Neue Datei – Datenpunkte

  10. Konfigurieren Sie die Datenpunkte, falls erforderlich. Jeder Wert mit einem Drop-down-Menü kann bearbeitet werden.
  11. Klicken Sie auf Next (Weiter). Daraufhin erscheint das Fenster New File - Points Selection (Neue Datei – Auswahl der Datenpunkte).
    Abbildung 6. Neue Datei – Auswahl der Datenpunkte

  12. Klicken Sie auf einen Datenpunkt, den Sie importieren möchten, und dann auf >, um ihn in den rechten Fensterbereich zu verschieben. Wiederholen Sie diesen Vorgang für alle gewünschten Datenpunkte. Wenn Sie alle Datenpunkte nach rechts verschieben möchten, klicken Sie auf >>.
  13. Klicken Sie auf Finish (Fertigstellen).
    Abbildung 7. Importdatei-Fenster

  14. Klicken Sie links im Navigationsmenü auf den Gerätenamen und dann auf Update (Aktualisieren). Alle konfigurierten Datenpunkte für die Importdatei erscheinen jetzt im Fenster.
    Abbildung 8. Datenpunkte für die Importdatei