Supported operating systems, databases, and web browsers - Facility Explorer - LIT-12012253 - Server - FX Alarm Portal - FX Server - FX Workbench - 14.x

FX Supervisory Controller Family Software Products Release 14.x Installation Guide

Brand
Facility Explorer
Product name
FX Alarm Portal
FX Server
FX Workbench
Document type
Installation Guide
Document number
LIT-12012253
Version
14.x
Revision date
2024-02-12
Language
English
Table 1. Supported operating systems and databases

Operating system

FX Supervisory Software Release 14.4 (Niagara 4.4)

FX Supervisory Software Release 14.6 (Niagara 4.6)

FX Supervisory Software Release 14.7 (Niagara 4.7)

FX Supervisory Software Release 14.8 (Niagara 4.8)

FX Supervisory Software Release 14.9 (Niagara 4.9) FX Supervisory Software Release 14.10 (Niagara 4.10) FX Supervisory Software Release 14.11 (Niagara 4.11) FX Supervisory Software Release 14.12 (Niagara 4.12) FX Supervisory Software Release 14.13 (Niagara 4.13)

Windows® Server 2008 R2 Standard/Enterprise, SP2 (64-bit)

N

N

N

N

N

N

N

N

N

Windows Server 2012 Standard/Enterprise, SP2 (64-bit)

N

N

N

N

N

N

N

N

N

Windows Server 2012 R2 Standard/Enterprise, SP2 (64-bit)

Y

N

N

N

N

N

N

N

N

Windows Server 2016

Y

Y

Y

Y

Y

Y

Y

Y

Y

Windows Server 2019 (64-bit)

N

N

N

N

Y

Y

Y

Y

Y

Windows Server 2022 (64-bit) N N N N N N N N Y

Windows 7 Professional/Enterprise/Ultimate (32-bit/64-bit)

Y

N

Y

Y

N

N

N

N

N

Windows 8 Professional/Enterprise/Ultimate (32-bit/64-bit)

N

N

N

N

N

N

N

N

N

Windows 8.1 Professional/Enterprise/Ultimate (32-bit)

Y

Y

Y

Y

N

N

N

N

N

Windows 8.1 Professional/Enterprise/Ultimate (64-bit)

Y

Y

Y

Y

N

N

N

N

N

Windows 10 (32-bit)
Note: Windows 10 Home is not supported.

Y

N

N

N

N

N

N

N

N

Windows 10 (64-bit)
Note: Windows 10 Home is not supported

Y

Y

Y

Y

Y

Y

Y

Y

Y

Windows 11

N

N

N

N

N

Y

N

Y

Y

VMware™ - ESXi 5.1.0

Y

Y

Y

N

N

N

N

N

N

VMware - ESXi 5.5

N

N

N

Y

Y

N

N

N

N

VMware - ESXi 6.0

N

N

N

Y - update 5224934

Y

N

N

N

N

VMware - ESXi 6.7

N

N

N

N

Y

Y

Y

Y

Y

VMware - Server 2

N

N

N

N

N

N

N

N

N

Microsoft Virtual Server 2008

N

N

N

N

N

N

N

N

N

Hyper-V® 6.1

N

N

N

N

N

N

N

N

N

Hyper-V version 10.0

Y

N

N

N

N

N

N

N

N

Microsoft Server 2012 Hyper-V

N

Y

N

N

N

N

N

N

N

Relational Database Server

MSDE 2000

N

N

N

N

N

N

N

N

N

Microsoft SQL Server® 2000

N

N

N

N

N

N

N

N

N

Microsoft SQL Server 2005/2008

N

N

N

N

N

N

N

N

N

MySQL® Server 5.1.61

N

N

N

N

N

N

N

N

N

MySQL Server 5.6

N

N

N

N

N

N

N

N

N

MySQL Server 5.7

Y

Y

Y

Y

N

N

N

N

N

MySQL Server 8.0

N

Y

Y

Y

Y

Y

Y

Y

Y

Oracle® 9i/10g

N

N

N

N

N

N

N

N

N

Oracle 11g

Y

Y

Y

Y

N

N

N

N

N

Oracle 12c

Y

Y

Y

Y

Y

Y

Y

Y

Y

Oracle 18c

Y

Y

Y

Y

Y

Y

Y

Y

Y

Oracle 19c

Y

Y

Y

Y

Y

Y

Y

Y

Y

DB2 8.1

N

N

N

N

N

N

N

N

N

HSQL (Controller only)

N

N

N

N

N

N

N

N

N

Microsoft SQL Server 2012

Y

Y

Y

Y

N

N

N

N

N

Microsoft SQL Server 2014

N

N

N

N

N

N

N

N

N

Microsoft SQL Server 2016

Y

Y

Y

Y

Y

Y

Y

Y

Y

Microsoft SQL Server 2017

Y

Y

Y

Y

Y

Y

Y

Y

Y

Microsoft SQL Server 2019

Y

Y

Y

Y

Y

Y

Y

Y

Y

Note: Oracle 12g is not supported. MySQL 8.0 and MySQL 5.7 are both tested with connector version: 8.0.13. Connector 5.1.46 works with MySQL 5.7 but does not work with MySQL 5.7.
Note: Niagara 4.11, 4.12, and 4.13 support Red Hat Enterprise Linux. However, Facility Explorer is not tested on Linux.
Table 2. Supported web browsers

Web browsers

FX Supervisory Software Release 14.x (Niagara 4.x)

Google Chrome (mobile, tablet, desktop)

Y

Chrome mobile: Android 8, 9, and 10

Microsoft Internet Explorer

N

Mozilla Firefox

Y

Microsoft Edge

Y

Safari (mobile, tablet)

Y

Safari iOS 12, 13

Niagara Web Launcher

Y

Note: The following browsers do not support the WbApplet (Wb Web Profile):
  • Google Chrome version 45 and higher
  • Microsoft Edge
  • Firefox version 42 and higher